Post Reply 
 
Thread Rating:
  • 1 Votes - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installing an 02 sensor eliminator
Author Message
4 Paws Online
High Mileage

MM 199 on BRP (Fancy Gap VA)
Posts: 997
Joined: Jun 2015
Post: #61
RE: Installing an 02 sensor eliminator
Installed then rode around the neighborhood a while, initial impression was it was a bit smoother. Took the bike on a 1600 mile jaunt and tried to pay attention to "my latest mod", yeah it does make it a bit smoother. My gas mileage is still excellent, consistently in the lower to mid 50's.

If I had the skills necessary I'd do Aussieflyer's mod, but I don't.

Best thing I learned from my dog"Never pass up the opportunity to go for a joy ride". - Dan D.
09-27-2016 06:07 PM
Visit this user's website Find all posts by this user Quote this message in a reply
The ferret Offline
Forum Moderator

Ohio
Posts: 18,758
Joined: Apr 2013
Post: #62
RE: Installing an 02 sensor eliminator
Lol... 1600 miles is a pretty good jaunt

.
2014 DLX and 2006 ST 1300
"a good chunk of life's problems can be solved by going for a ride"...Guth ..... "daily" ...Ferret
09-27-2016 08:41 PM
Find all posts by this user Quote this message in a reply
Jeya Offline
Break-In Period

Singapore
Posts: 21
Joined: Aug 2017
Post: #63
RE: Installing an 02 sensor eliminator
Hi guys, im riding the RS and i just put on the o2 eliminators. Bike feels much more responsive but it could be a placebo. Anyways, after 30mins i started getting am efi light. Bike runs fine. Just the light. Anyone else have this problem? How do i get rid of the fault light?
10-29-2017 11:18 AM
Find all posts by this user Quote this message in a reply
Gumby 1100 Online
Running Like a Top

Cambridge, Ontario, Canada
Posts: 446
Joined: May 2014
Post: #64
RE: Installing an 02 sensor eliminator
(10-29-2017 11:18 AM)Jeya Wrote:  Hi guys, im riding the RS and i just put on the o2 eliminators. Bike feels much more responsive but it could be a placebo. Anyways, after 30mins i started getting am efi light. Bike runs fine. Just the light. Anyone else have this problem? How do i get rid of the fault light?

You wrote "eliminators" (plural), so I am assuming you installed 2 plugs, ONE for each O2 Sensor. I have a single sensor on my 2014 Canadian, so it was easy to follow the lead from the sensor in the exhaust up to the connection behind the right side cover. With my bike the change was drastic and noticeably better, with engine braking reduced significantly making slow speed driving much more enjoyable. That may only be the case, however with the 4 into 1 exhaust. The affect on bikes with 4 into 2 (dual mufflers) may not be as noticeable.

Am I correct in understanding that the RS has the left bank sensor connector behind the left side cover and the right bank sensor connector behind the right side cover?

I think that the only time someone got an EFI light was when the Plug was put in the wrong location or they only installed ONE Plug on a bike that required TWO.

NOTE: There are at least two connectors behind the right side cover that look very similar...Only one of them leads to the O2 Sensor in the exhaust.

Hope this helps!

2014 CB1100A (Canadian) #068 (Sold)
2018 Harley-Davidson Road King
10-29-2017 11:50 AM
Find all posts by this user Quote this message in a reply
Jeya Offline
Break-In Period

Singapore
Posts: 21
Joined: Aug 2017
Post: #65
RE: Installing an 02 sensor eliminator
Yeah i have 2. I might go trace the wires again after you mentioned that some connectors look the same. But what i find funny is that i only got a fault light 30mins into riding and not immediately. Hmm.. suddenly i miss carbs haha
10-29-2017 07:31 PM
Find all posts by this user Quote this message in a reply
peterbaron Offline
1st Service Completed

Brampton, ON, Canada, '13 CB1100A
Posts: 137
Joined: Jan 2016
Post: #66
Playing with 02 sensor
What may happen to your bike if you take modification into your own hands without proper/technical knowledge....

"...O2 sensor works by constantly sending signal to ECU/ECM/PCM to help vehicle run efficiently as well as to reduce emissions...
... improperly working O2 results vehicle in running less efficiently...
....the wrong mix of gasoline and oxygen can increase pollutants that exit your bike exhaust, thereby harming the environment, as well as potentially causing your catalytic converter to fail or even damage your engine...."

>>>>>>> #1 CATALITIC CONVERTER KILLER IS HC <<<<<<<<<<<<

".... a properly working oxygen sensor is a necessity for any vehicle....."

I know , I will face a lot of criticism but at least, I told you the truth....

Good luck!!
(This post was last modified: 10-30-2017 07:21 AM by peterbaron.)
10-30-2017 07:03 AM
Find all posts by this user Quote this message in a reply
redbirds Offline
Been There

Patterson, GA, USA
Posts: 3,699
Joined: Jan 2014
Post: #67
RE: Installing an 02 sensor eliminator
My understanding is that the O2 sensor on the CB is there to allow a rich condition at startup and a lean condition as the motor warms. I replaced mine with an O2 emulator 2 years ago. It rid the bike of a slight stumble at low speed and part throttle. Bike runs better and fuel mileage has been unaffected.

Philippians 4:8 (NIV)
Finally, brothers and sisters, whatever is true, whatever is noble, whatever is right, whatever is pure, whatever is lovely, whatever is admirable—if anything is excellent or praiseworthy—think about such things.
10-30-2017 10:07 AM
Find all posts by this user Quote this message in a reply
itstuantran Offline
Break-In Period

Vietnam
Posts: 30
Joined: Apr 2017
Post: #68
RE: Installing an 02 sensor eliminator
Jeya, any updates? I'm riding the 2017 RS as well and have ordered a pair, dont know if your EFI indicator still lights up?
Thanks
(10-29-2017 07:31 PM)Jeya Wrote:  Yeah i have 2. I might go trace the wires again after you mentioned that some connectors look the same. But what i find funny is that i only got a fault light 30mins into riding and not immediately. Hmm.. suddenly i miss carbs haha
(This post was last modified: 12-10-2017 07:23 PM by itstuantran.)
12-10-2017 07:22 PM
Find all posts by this user Quote this message in a reply
Guth Offline
Forum Founder

Portland, OR
Posts: 3,115
Joined: Apr 2013
Post: #69
RE: Installing an 02 sensor eliminator
I'm also curious to know how Jeya is getting along.

(10-30-2017 10:07 AM)redbirds Wrote:  My understanding is that the O2 sensor on the CB is there to allow a rich condition at startup and a lean condition as the motor warms. I replaced mine with an O2 emulator 2 years ago. It rid the bike of a slight stumble at low speed and part throttle. Bike runs better and fuel mileage has been unaffected.

Ditto.

2013 CB1100: Placed deposit on Nov. 12, 2012; Received delivery on April 5, 2013.
12-10-2017 07:57 PM
Find all posts by this user Quote this message in a reply
Post Reply 


[-]
Recent Posts
2018 Harley Soft Tails
jimgl3, using my moderator almost-supe . . .jimgl3 — 01:14 PM
A note about this forum, it's history, an ap...
Guth - You have my support and thanks.BayAreaRick — 12:56 PM
new battery won't crank
thanks guys! all good info! what a gre . . .jimgl3 — 12:50 PM
ROX 5cm bar riser report
well, I was looking at them too, but the . . .jimgl3 — 12:47 PM
2018 West Coast Rally
I am VERY interested, but can't commit u . . .BayAreaRick — 12:45 PM
CB1100 Lock
OK guys. Maybe I am stupid or just stil . . .teamvisegrip — 12:43 PM
New user
welcome!!jimgl3 — 12:38 PM
Tire Options for our CB1100
ULV, sorry, but you are wrong. LOL! . . .jimgl3 — 12:37 PM
A note about this forum, it's history, an ap...
this is the awesomeist coolest most best . . .jimgl3 — 12:33 PM
A note about this forum, it's history, an ap...
But I never, ever, violated any of the p . . .Django — 12:24 PM

[-]
Statistics
» Members: 3,949
» Latest member: mmumford
» Forum threads: 10,161
» Forum posts: 183,310

Full Statistics

>
Forum Jump: